Back to overview
Downtime

Etherlink Mainnet block production outage

May 04 at 02:30pm BST
Affected services
Etherlink [Block Production]
Etherlink [Relay - Block Production]
Thirdweb [Etherlink - Block Production]

Resolved
May 04 at 03:51pm BST

The sequencer was restarted and new blocks are being produced. Root cause investigation underway.

Created
May 04 at 02:30pm BST

The Etherlink sequencer node is currently down, affecting transaction processing on the network and production of new blocks. Coordination with the sequencer operator is in progress to restore services. No funds are at risk.