Back to overview
Downtime

Etherlink [Block Production] and Etherlink [Read Transactions - eth_call] are down

May 20, 2025 at 10:14pm UTC

Resolved
May 20, 2025 at 10:17pm UTC

Etherlink [Block Production] and Etherlink [Read Transactions - eth_call] recovered.

Created
May 20, 2025 at 10:14pm UTC

Etherlink [Block Production] and Etherlink [Read Transactions - eth_call] went down.